Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I have created one send email workflow using SPD 2010 for my custom list (like Licnese Management). Now, I need to start that workflow only on specific condition like, If Deactivation Date / Valid Upto Date is change.

For that, I used Visual Studio Event Receiver ItemUpdating Event for that list & wrote a code for to check everything. Now, I want to start the workflow if condition matched. hence i wrote following code...

spwfmanager.StartWorkflow(properties.ListItem, spwfassociation, spwfassociation.AssociationData);

with other parameters like,

spwfmanager.StartWorkflow(properties.ListItem, spwfassociation, spwfassociation.AssociationData, true);
spwfmanager.StartWorkflow(properties.ListItem, spwfassociation, spwfassociation.AssociationData, SPWorkflowRunOptions.Asynchronous);
spwfmanager.StartWorkflow(properties.ListItem, spwfassociation, spwfassociation.AssociationData, SPWorkflowRunOptions.SynchronousAllowPostpone);

now, If i used without additional parameters it doesn't work (I mean i didn't get an email) but workflow status is completed.

If I use start Immediately = true (additional Parameter) then it start & i also received an email but till that moment item edit window (popup) gets as it is. so, user may confused why this popup not going even i click save/ update and it click twice/ thrice.

If I use SPWorkflowRunOption.Asyncronous (additional Parameter) then I didn't received any email and workflow status would be "Start" not even "In Progress" or "Completed". I thought it would be in start but after 5-7 minutes it would be "In Progress" and I will received an email. But I was wrong. Not getting any email.

Friends, If you found any such issue & resolved that then please let me know

share|improve this question
    
if Immediately=true starts the workflow, that is perfect... For closing the popup, you can use properties.Status=Continue, However it is by default Continue and it should work! –  Arsalan Adam Khatri Nov 7 '12 at 7:19
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.