SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have just done a dbattach upgrade of our servers and so far everything has come up very nicely.

Except for the Search service. I cannot get Search to crawl our 4 web applications.

The crawl finishes with errors everytime.

I get the following error.

"An unrecognized HTTP response was received when attempting to crawl this item. Verify whether the item can be accessed using your browser. ( Error from SharePoint site: HttpStatusCode GatewayTimeout The remote server returned an error: (504) Gateway Timeout. )"

Does anybody recognize this.

Server configuration:

* WFE: windows server 2008 R2, Sharepoint 2010 enterprise, SSL(wildcard certificate)
* DB: windows server 2008 R2, SQL Server 2008 R2 

Things i've already tried:

* Used another browser
* Set disableloopbackcheck to 1
* iisreset
* reset index
* modified the hosts file
* verified DB account
* extended timeout settings
* turned off "warn on ssl errors"

Any help would be greatly appreciated. Need to go live in a couple of days.

Cheers

share|improve this question

Have you checked that your Content Sources are still correct? Does the crawler account have the right permissions?

Although the error seems to indicate something on the IIS configuration.

share|improve this answer

You need to add the search account to the user policy in web application settings as 'full read'

share|improve this answer

Please check OSearch permissions..

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.