SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'd created a custom column on a document library using the settings > create column menu. We used to be able to specifiy the value on this custom column when uploading a file or by going to the 'edit properties' page and changing it there.

Suddenly, the ability to edit the value has gone. It no longer appears on the upload or edit properties pages. I can still see the column in the default library view and can edit the values using the edit in datasheet option.

Does anybody have any idea what might have been done to remove this functionality, and how to restore it?

share|improve this question
up vote 0 down vote accepted

This sounds related to Content Types.

The files which you are creating or editing may be using a content type which your custom column does not belong to.

Go into the Document Library Settings > Advanced Settings > and turn on "Allow management of Content Types".

This should let you select which content type to use, and you should be able to find your custom column in the new/edit pages that way.

share|improve this answer
thanks, that's fixed it. any idea how this could have happened? i've got other document libraries set up without the management of content types turn on and they work fine. – helpmeplease 0 secs ago – Anonymous Aug 27 '10 at 10:03

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.