Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I have a licensed Sharepoint 2010 Enterprise edition and Office 2010 standard. In my project, I have a document library for which I would like to enable approve/reject and publish/unpublish features for the documents. I am able to activate approve/reject feature from version settings,but i am unable to activate the publish/unpublish feature .

I tried these commands

stsadm -o activatefeature -filename publishing\feature.xml -url "http://sp2010/sites/TestSiteCol/" -force

stsadm -o activatefeature -filename publishingresources\feature.xml -url "http://sp2010/sites/TestSiteCol/" -force

stsadm -o activatefeature -filename publishingSite\feature.xml -url "http://sp2010/sites/TestSiteCol/" -force

stsadm -o activatefeature -filename publishingweb\feature.xml -url "http://sp2010/sites/TestSiteCol/" -force

stsadm -o activatefeature -filename publishinglayouts\feature.xml -url "http://sp2010/sites/TestSiteCol/" -force

stsadm -o activatefeature -filename navigation\feature.xml -url "http://sp2010/sites/TestSiteCol/" -force

stsadm -o activatefeature -name PublishingResources -url "http://sp2010/sites/TestSiteCol/"

stsadm -o installfeature -name "http://sp2010/sites/TestSiteCol/"

Every command shows successfully activated, but i am unable to see "Office SharePoint Server Publishing Infrastructure" feature in

Site Actions > Site Settings > Site Collection Administration > Site Collection Features

in my top level site collection settings.

Are there any settings to activate the publishing feature in my site collection?

share|improve this question
2  
Have you tried PowerShell? Enable-SPFeature -Identity "PublishingSite" -Url "webapp/sitecollection"; for the site collection feature and then Enable-SPFeature -Identity "PublishingWeb" -Url "webapp/sitecollection"; for the site feature (assuming you want publishing in the root of your site collection)? –  shufler Nov 2 '12 at 13:42
add comment

3 Answers

Finally i found the answer. my mistake is i chosen

document library settings > Versioning settings > Document Version History > Create major versions.

but the solution is

after activating the above features in document library settings > Versioning settings > Document Version History > we have to choose "Create major and minor (draft) versions".

then only publishing button will enable.

share|improve this answer
add comment

Run iisreset after the command.

stsadm -o activatefeature -name PublishingWeb -url https://<site>
iisreset
share|improve this answer
add comment

Make sure Enterprise Features are Active in Central Administration.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.