Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I've got a site that only has one available page layout for editors to use. it's the default page layout for the site and no-one else has access to change it.

However, when I create a page and save it if I just keep hitting F5 every 10 or so refreshes it will load a page layout from one of the other sites in the site collection.

If I edit the page at that point, the only option I have in Page > Page Layout from the ribbon is the page layout that's being loaded erroneously even though if I go back into the page layout config in site settings it's still showing the correct layout as the only one available and set as default.

Any ideas what might cause this?

share|improve this question
    
Did you write anything to set the page layout programmatically? –  Hugh Wood Nov 2 '12 at 14:24
    
Nope, we're just using the standard Sharepoint functionality for setting page layouts. I just realised it's also loading nav for a different site as well (not even the same as the page layout!) –  Ben Nov 5 '12 at 13:39
    
Have you tried to run a database repair? I can't help but think that something has become corrupted, maybe a corrupted index. If there is nothing extra running, no custom code etc, then a file/database corruption is the only thing on my mind at the moment. –  Hugh Wood Nov 5 '12 at 13:48
    
Not sure if I can do that myself (we're using sharepoint online). Might be one for MS support. Thanks for the advice.) –  Ben Nov 7 '12 at 10:58
    
I didn't see SharePoint online! Right in that case but a ticket straight in and get them to look. Definitely the way forward. –  Hugh Wood Nov 7 '12 at 11:06
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.