Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I have a weird problem. I'm making an application page public using

protected override bool AllowAnonymousAccess
    {
        get
        {
            return true;
        }
    }

I use the same way for other application pages and it's ok, but for this one it doesn't work as it should be. I don't understand why..

share|improve this question
    
Have you tried to attach a debugger to see if you get to the page, but just have some code which access something which requires a login? –  Per Jakobsen Oct 31 '12 at 8:43
    
YES, that was the problem :D. –  MIlena Oct 31 '12 at 10:44

2 Answers 2

Make sure that your application page inherits from UnsecuredLayoutsPageBase and that anonymous access is enabled for the IIS site running the SharePoint application.

share|improve this answer

This will not work if publishing features are turned ON on the site since they remove LimitedAccess permission level which is required for Anon access. Try on a plain team site with all publishing features OFF.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.