Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I'm using JQuery tabs in a SharePoint 2010 environment. The files are in /_layouts/scripts/ and linked via the only one master page. The .js files are linked using

<SharePoint:ScriptLink language="javascript" name="/_layouts/scripts/jquery-1.8.2.min.js" runat="server"/>
<SharePoint:ScriptLink language="javascript" name="/_layouts/scripts/jquery.ui.core.min.js" runat="server"/>
<SharePoint:ScriptLink language="javascript" name="/_layouts/scripts/jquery.ui.widget.min.js" runat="server"/>
<SharePoint:ScriptLink language="javascript" name="/_layouts/scripts/jquery.ui.tabs.min.js" runat="server"/>
<SharePoint:ScriptLink language="javascript" name="/_layouts/scripts/jquery.cookie.js" runat="server"/>

I'm not even sure if I need all of these files, but it's working for site collection admins...

I've tried putting the files in the style library and also using a regular script tags (for the same 5 .js files for the _layouts and style library) for both the library and the _layouts locations and that didn't help.

<script scr="..." type="text/javascript"></script>

Users have read permissions to the site and also restricted read in the style resource readers group. I should mention that we are using load balanced servers with TMG and all of the .js files are on both servers. I've tried browsing each server directly and I'm getting the same result. I'm using a Mega Menu and Modal windows in the site and they work fine and I'm not getting any errors in IE or FireFox developer.

Any help would be much appreciated!!

share|improve this question
add comment

3 Answers 3

Make sure the master page is checked in, published as a major version, and approved.

The symptoms you are describing are exactly what happens when a masterpage (or any reference within the master page stored in a library with versioning and approval) is not published and approved. Things work flawlessly for those with full control but not for visitors.

share|improve this answer
    
I have forgotten this in a couple cases. The scripts would work for me but not my users. Once I checked in and approved the changes, everything worked. Good suggestion. –  Robert Kaucher Oct 27 '12 at 2:49
    
I double checked all of my linking files and the Master page and everything is checked in, published as a major and approved. –  SMFH Oct 29 '12 at 19:20
add comment

Can you try putting the files in a nested folder?

Such as: /_layouts/MyProject/scripts/jquery.cookie.js

Maybe the root _layouts has permission issues since it contains system pages (like settings.aspx, viewlsts.aspx, etc.)

share|improve this answer
    
I tried this, but still the same. –  SMFH Oct 29 '12 at 19:19
add comment

Putting the juquery-ui.css in the hive instead of the style library solved my issue. I'm really not understanding why because I have other stylesheets in the style library and they are working just fine. And the style resource readers group with my domain users account has restricted read to the style library.

Thank you all for your help and taking time to respond to my question and I hope this helps someone else.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.