Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

enter image description hereIn one existing site collection all document libraries are suddenly showing the _cts folder.

Any idea how to fix it?

share|improve this question
    
can you provide a screen shot? –  David Lozzi Nov 5 '12 at 16:16
    
@DavidLozzi screenshot posted. –  L.V. Sharepoint Architect Nov 6 '12 at 11:16
    
any customizzation done, solution installed, patch applied etc in a time range compatible with the issue? Seems a bug to me, so I would search for some change you have done when you first discovered the problem. –  SPArchaeologist Nov 9 '12 at 9:05

4 Answers 4

up vote 2 down vote accepted

For others searching for an answer to this problem, we eventually fixed the issue like this:

In the list definition where you define the content types, in the targetName attribute we were specifying the content type name like this: "_cts/MyContentType"

We've changed it to exclude the "_cts" part and now the issue no longer shows up (and functionality still works as expected)

<ContentTypes>
     <ContentTypeRef ID="0x010060000000000000000000000000">
         <Folder TargetName="MyContentType" />
     </ContentTypeRef>
</ContentTypes>

EDIT: This fixes the issue on newly created sites, to remove it on existing sites you need to remove them manually (or use a PowerShell script).

share|improve this answer
    
amazing, I could fix it with this, you are awesome –  L.V. Sharepoint Architect Apr 8 '13 at 8:03

-cts folder belongs to so-called hidden URL structure of a sharepoint web site.

By default only users that (or who) are members of the Site Owners group and Designers group see it (as well as All Files tab in Sharepoint Designer 2010).

In Sharepoint Foundation the Designers group is not created by default at all.

Site collection administrators also can be limited but at the site collection but web app level.

At site collection level

these settings are configured, in browser, at top level site of site collection (navigate to root site of site collection) > Site Actions > Site Settings > Allow Site Owners and Designers to See the Hidden URL structure of their Web Site .

At web app level

it is configured in Windows Start > All Programs > Microsoft Sharepoint 2010 Products > Sharepoint 2010 Central Administration > Manage Web Applications under Application Management section > choose a specific web application > on ribbon, the Web Applications tab (under Manager group section)

share|improve this answer
1  
+1 I didn't know about this setting, thank you! But if the _cts folder was copied due to wrong receivers to all libraries in SC, this tip maybe will not help him. If it is copy... –  Molik Nov 6 '12 at 16:02
    
Yeah he would have to make sure it excludes the hidden folders and then exclude then fix his workflow/event receiver that he is using. –  Hugh Wood Nov 7 '12 at 8:53
    
I checked and they were all enabled at web app level, however at site collection level, they are unchecked. I tried disabling them at web app level but I still see no difference. the _cts folder is still there. weird!!! –  L.V. Sharepoint Architect Nov 7 '12 at 11:39
    
additionally, I added a new user into a group which has only read access to the site collection, I used that user to login, and he can also see the hidden _cts folder in all document libraries. –  L.V. Sharepoint Architect Nov 7 '12 at 11:49

I thought that _cts virtual directory is for site only, maybe you activate new content type or document set via feature for whole site. Is it accessible for users? Is it empty?

share|improve this answer
    
its not empty, inside cts there are folders with the content type names, and inside each of those folders there is a document template. but we didnt activate new content types or document sets via features. We do have feature upgrading event receivers that add fields to existing content types, mark some fields as not visible, etc, etc things like that –  L.V. Sharepoint Architect Nov 5 '12 at 19:36
    
Try to add something, if changes will be distributed somewhere else or delete it if something happens, maybe it appears again. Folder can't be simple invisible inside UI, you can set unique permission to it or hide it from view, hide it especially in Explorer view etc. So remove and test your event receiver first, it maybe interact with something that is in this SC only. –  Molik Nov 6 '12 at 11:48

Try using Request Filtering in IIS, click the hidden segments tab, and add _cts.

HTH

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.