Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

we have a proxy-server running which routes all the external-traffic in a ssl-context since we are using basic-authetication for external users. For internal users we have kerberos and http running. Unfortunately if im connecting from outside, almost every ribbon-buttn is grayed out. see here

If the user is from the intranet, can use kerberos and normal http everything works fine..

these dudes had the same issue but unfortunately there is no solution or hint.. http://forums.citrix.com/thread.jspa?threadID=303918

To narrow it more down, i experience that the notification box is stuck in loading condition when i expand the dropdown menu for a list item in a document library. See in screen below notification error

share|improve this question
1  
This is a weird one, try emailing the guy on the Citrix forum who had the issue, perhaps he has solved it now? –  Hugh Wood Oct 24 '12 at 10:05
1  
Proxy server is almost certainly the culprit here, the fact that you're using basic auth is also contributing to this problem I would wager. –  pigeon Oct 24 '12 at 12:54
1  
Because of proxy probably javascripts are not loading. You can check your console for error and check network trafic to see if scripts are loading. –  m.jedrzej Oct 24 '12 at 13:02
    
i did this yesterday and some js errors came up. somehow i get http context back and browser prompts an insecure error.. im currently diggin into it and will provide the solution when i got it ;) somehow i messed up the AAM configuration –  Peter Oct 25 '12 at 11:47
add comment

1 Answer

up vote 0 down vote accepted

I emailed one of the guys from the citrix board. He supported me with this file: http://www.f5.com/pdf/deployment-guides/f5-sharepoint-2010-dg.pdf

Important are pages 1-4 to 1-7.

Basically its pretty simple stuff. i just changed the public url to https and added an internal url with http.. solved my issues.

ribbon loads properly and context menu is available as well!

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.