Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I have a web application with FBA configured and have set up AAM's on it: One for Internal users/zone (http://xyz.com) and one for External users/zone (https://xyz.com)

I have extended the web application to use ssl & a custom login page with anonymous access enabled(This is for the users to get to the custom login page).

I am able to browse to both the AAM specified url's.

However, when I browse to the https://xyz.com, I do not see the Custom login page but just a generic page (of my custom solution) that displays "NO authenticated user". More importantly, I am able to get to the login page if I were to type in https://xyz.com/_layouts/customlogin.aspx

Its all good from there.

Please note that when I do remove the anonymous access on the External zone users are able to get to the login page but cannot navigate or are denied access (on clicking the page simply refreshes) to the sign up and forgot password pages through the links on the login page.

How do I get to fix this url so when users browse to https://xyz.com they get to see the login screen and have access to the Forgot password and Sign up pages on clicking on the respective links??

Thanks

share|improve this question
add comment

1 Answer

up vote 1 down vote accepted

You should remove anonymous access on the web application's Extranet zone, and allow access to the login page in your web.config file. With anonymous access enabled there is no validated authentication required so it would make sense that your login page would not be displayed (the user is already authenticated as anonymous).

In your web.config try something like:

<location path="_layouts/MyLogin.aspx">
  <system.web>
    <authorization>
      <allow users="*"/>
    </authorization>
  </system.web>
</location>

This will grant authorization (not authentication) to anonymous users accessing the site. Also, this doesn't open up the rest of the site to anonymous users, as opposed to enabling anonymous authentication in Central Administration.

share|improve this answer
    
Thanks rjcup! Here is the thing though; I have disabled anonymous access on my External Extended web app. I can now get to the login page when I browse (https:xyz.com) However the two links "Sign up" and "Forgot Password" links on the login page that point to /pages/SignUp.aspx and /pages/ForgotPwd.aspx cannot be accessed. As mentioned before, on clicking these links the page simply refreshes with no error whatsoever. Now I tried adding /pages/SignUp.aspx in my config file the way you suggested, but ended up with a 500 server error while trying to access the site after. Any thoughts? –  user7400 Oct 23 '12 at 18:35
    
basically I need to able to grant access to xyz.com/pages/ForgotPwd.com –  user7400 Oct 23 '12 at 18:39
    
Move them to the layouts folder? –  RJ Cuthbertson Oct 23 '12 at 19:26
    
That was my first thought as well, but wouldnt that break references in the custom solution if any? –  user7400 Oct 23 '12 at 19:32
    
It would break URL references to them, yes. Is this your solution or someone else's? –  RJ Cuthbertson Oct 23 '12 at 19:55
show 3 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.