Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

We have a corrupted sitecollection where lists are behaving strange in production, but they are working fine on acceptance and test with the exact same deployment steps and scripts.

Our best guess is that the list got corrupted somewhere: Examples of errors: one field that was invisible now its visbiible One field that was marked as required, not its set as not required and viceversa. Ordering of fields is not correct.

Becase ACC and Test are fine, we are writing a console app to read the settings from one server and replicate it into the other server.

I have done the most part: But the question is:

If I remove ALL the fields links from one content type, and add them back again in the correct order, then the lists that use that content type will lose its data? if not, are there any other consequences?

thx

share|improve this question

1 Answer 1

up vote 1 down vote accepted

I don't believe that removing the FieldLink will remove the data - indeed, this is a problem I've come across a couple of times. As far as I know, provided the internal names of the fields are correct (and the field types the same), then the data should be okay.

However - it sounds like you've a bit of a problem, so I would recommend backing up your production content DB before trying this fix. I would also recommend understanding exactly what caused the corruption in the first place; you may find you have another problem that wasn't obviously related to the effects you were seeing.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.