Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

In sharepoint search, if you go to search server admin, then look at the managed metadata properties, then click on a managed property, it will say something like "Number of Items found with this property: 5".

Is there any way to ask it to show me which 5 document URLs are associated with it and which values were indexed for the property?

I tried doing a search with wildcards like:

myprop:* and myprop:

with no luck. Nothing is returned.

When I search for the values that should have been set for the property, the documents don't show up.

I'm hating this black box search engine :-P

share|improve this question

3 Answers 3

If you click on the Crawled Property link (crawled properties usually begins ows_ as opposed to the Managed properties, which are linked to the crawled property) the page should have a link to some items with that property in use (and set).

You may need to ensure the property is included in the index before it'll show up in that page.

For me, this works in the page crawledproperty.aspx, rather than managedproperty.aspx (which only shows a count, no links).

Additional: If you make any changes here, you must perform a Full Crawl before anything will show up via the Search API (web UI search or custom code which uses search).

share|improve this answer
    
Interesting...under Crawled Property, it lists zero documents; the properties that do have documents have sample URLs listing a subset of the documents (wish it included all of them). But under the matching Managed Property, it lists 5 items. Now the puzzle is why it shows items for the Managed property but no documents for the crawled property :-P –  Anonymous Aug 23 '10 at 19:59
    
Is it an out of the box crawled property you're mapping to? If so, which, and I'll have a play and let you know what the outcome is on my end. –  James Love Aug 23 '10 at 20:24
    
'fraid not...it's a custom property but added to the Office category. Thanks for the offer though... –  Anonymous Aug 23 '10 at 21:28
    
Is the checkbox for " Include values for this property in the search index " in the Edited Crawled Property page selected? If not, check it and do a full crawl, see if that works. –  James Love Aug 24 '10 at 7:55
    
Yep, that checkbox is checke –  Anonymous Aug 24 '10 at 15:26

Try the Zevenseas SearchCoder to test out FullTextSqlQuery against your search app:

http://mosssearchcoder.codeplex.com/releases/view/49490

P.S. it works for both 2010 and 2007

share|improve this answer

Have you tried to log in as Default Content Access Account? This account can see every search result.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.