Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

Using SharePoint 2007, when the "search: This site" in share point is used with default windows 7 (English UK) system language its displaying results. However, when other language is used as default system language in Windows 7, the search in share point is not displaying any results.

share|improve this question
add comment

1 Answer

up vote 0 down vote accepted

This is because it is triggering a different search set and using the German setup, for this search it would appear you have to enforce English as the language and this is how you do it:

[2007]

I don't have a copy of 2007 running so from memory it is (I tried Googleing it but couldn't find a post on it):

Create a copy of the existing search results page.

Alter the new page to bypass the ACCEPT-LANGUAGE header which SharePoint uses to set the language.

Change the search options to use this new search results page instead.

[2010]

Go to the search results page as administrator

Put the page into edit mode and edit the core results web part

In Result Query Options change the Query Language to the preffered language.

If you want it to be multilingual this all comes down to language auto detection and the German language. The word breaker is the key here, it breaks words up for indexing and it does this in German very differently to English. The German specifics are here detailed in a kb issue with German search results. Unfortunately you are only just scratching the surface of search configuration for multilingual usage, an investigation into the words indexed by the crawler would possibly be a good way to go, you can create yourself a scope for each language you desire and look at the results that way.

share|improve this answer
    
After editing the Search Core Results Webpart, there is no Query Language option in Result Query Options.We use MOSS 2007 –  user9432 Oct 24 '12 at 5:13
    
For future reference, you should state this in your post and tags. –  Hugh Wood Oct 24 '12 at 7:52
    
Not for 2007 that I know of sorry, it's because it is a browser header picked up in the code. –  Hugh Wood Oct 25 '12 at 10:30
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.