Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I have a site on moss 2007 (SP2) / wss 3.0 (SP2)

The business then wanted to set up a staging area for the site, instead of direct editing, so I backed up then restored the live site to a new blank web app on a staging server, and set up content deployment from the staging site to the existing live site. All has gone well and content deployment is working as expected.

I don't know if this is related or not, but when a member of the contributor group visits the staging site to edit a page (authenticated), it doesn't show the site actions button (global links) or welcome info in the header of the page. If the user is a member of the Owners permission group, the Site Actions button shows as expected.

Contributor group has standard edit options and is active on the site.

How can I make this button show for contributing authors? (current work-around is to go via Site Content and Structure)

share|improve this question
    
groups with permissions including Manage site hieararchy and above all show the Site Actions button –  stu Oct 23 '12 at 3:35
add comment

2 Answers

up vote 1 down vote accepted

You can edit the permissions of the contributor group to include the "Manage Hierarchy" option.

Site Settings -> Site Permissions -> Edit User Permissions

enter image description here

share|improve this answer
    
Thanks Carel, that does work, however, it gives the content editors a little too much control over the site including the ability to delete it :) –  stu Oct 23 '12 at 18:11
    
I will mark this as an answer. Though I will still need to discover why this has happened, I was able to create a custom permission group that allowed the global links to be displayed for the authors. –  stu Oct 25 '12 at 18:25
add comment

There will be some conflict while content deployment to staging server. Try replicating Master Page from your production environment and see if it can resolve your issue. Or create new default master page and apply the changes as per the production site.

share|improve this answer
    
Thanks Dipesh, I have tried this to no avail. Still looking for an answer as to why this is occurring. –  stu Oct 24 '12 at 0:58
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.