SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I recently created a SharePoint 2010 standalone VM with ADDS. As soon as I start User Profie Synchronization service, the service status shows starting and then stops in a minute.

Googling, I came across an MSDN article which says that user profile synchronization is not supported on standalone installation of SharePoint 2010.

So was wondering that is there any ways through which we can workaround this issue and get it working on SharePoint 2010 standalone VM.

appreciate any help.

share|improve this question
up vote 0 down vote accepted

You actually need to start this service by Farm Administrator account. In my case - I change Service Account to Local Administrator (by this account I install SharePoint), who also been Farm Administrator.

Another way described here:

share|improve this answer
Thanks Vitaly, but what does it mean start the service by Farm Admin? I am logged in as the Farm account (account used to install SP2010) and then also I get this error. However I have created a seperate service account (SPServiceAcc) which owns all the service apps. So when I try to start the service, I am navigated to a page asking the credentials of my service account. So do I need to change the service account to farm? – Vivek Aug 23 '10 at 14:51
I create separate service account too, but for User Profile Sync, as I understand need more rights than just managed account, because its running Forefornt Identity Windows Service. Go to Security - Configure service accounts - and set to User Profile Sync Service your local admin account and reboot machine ;). This need help – Vitaly Baum Aug 23 '10 at 16:05
I tried setting service account for User Profile Sync Service to mu local administrator and restarted the machine but it did not reflect when i attempt to start the service. I then had to set my local admin account as my farm admin in Configure service accounts and then it worked. – Vivek Aug 24 '10 at 6:18

Just as you say - you cannot use the UPA in Standalone configuration. You need a server Farm setup. I wouldn't even try a workaround with UPA on standalone - enough trouble getting it rollin on a farm already :-)

Configuring a server farm does not take much more time or problems compared to a Standalone, esp if its a demo or dev box. Almost the opposite - since you spend time trying to fix things not supported.

share|improve this answer
Thanks Wictor. Actually I am running the VM on my laptop using the boot from VHD configuration, so having a farm setup in that case is not an option for me :-(. – Vivek Aug 22 '10 at 14:45
You don't need a multiple servers to run a farm setup! Just so NOT select the Standalone option and install SQL Server (express/standard/developer...) b4 attempting to install SP – Wictor Wilen MCA MCM MVP Aug 22 '10 at 17:19
Oh, thanks for the tip Wictor. I will try this out today! – Vivek Aug 23 '10 at 2:54

this can be configured in farm admins group policy. User sharepoint online instead.

share|improve this answer

Accordign to the following article

this feature is not exist in the Standalone installation

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.