Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

Another interesting warning which has stumped me,

The identity of application pool SharePoint Central Administration v4 is invalid. The user name or password that is specified for the identity may be incorrect, or the user may not have batch logon rights. If the identity is not corrected, the application pool will be disabled when the application pool receives its first request. If batch logon rights are causing the problem, the identity in the IIS configuration store must be changed after rights have been granted before Windows Process Activation Service (WAS) can retry the logon. If the identity remains invalid after the first request for the application pool is processed, the application pool will be disabled. The data field contains the error number.

This is the error that follows, which makes sense given the above right?

Application pool SharePoint Central Administration v4 has been disabled. Windows Process Activation Service (WAS) encountered a failure when it started a worker process to serve the application pool.

Steps I have checked: Spadmin account is part of the local admin group, password is correct has access in IIS_IUSRS, has access to database, runs the SecurityToken service which has started ok, still not sure what I am missing. It points to a problem with the account but can't figure it out.

Please can anyone help?

share|improve this question
add comment

4 Answers 4

up vote 2 down vote accepted

Ok I figured this one out, the Local Security settings had been modified domain wide so that only one specific account had Allow Batch Logon rights. I added the SP Farm account, which is the account that runs the app pools, to the Allow Batch logon rights and everything worked wonderfully.

Thanks to 3rd party company that added their own account to the Default domain policy you wasted 2 days of my life.

Thanks Matthew Hughes

share|improve this answer
add comment

I am running my SP 2010 site with ASPHostCentral and initially, I encountered the same issue like you did. There are things to check to get rid of this error message:

  1. Please make sure your CA application pool is running under Administrator Identity
  2. Please make sure you switch your "Enable 32-bits Application Mode" to FALSE

Yes, that is the basic requirements of SP 2010 running under Windows 2008 R2 64-bits edition. If you were to install a new SP 2010 site on this farm, you also need to make sure:

  1. The application pool identity of that particular site is set to NETWORK SERVICE
  2. Please make sure you switch your "Enable 32-bits Application Mode" to FALSE
  3. You should consider setting up an NT AUTHORITY\NETWORK SERVICE on your Content Database.

You can preview my demo site at http://english.sharepointroad.com OR http://spanish.sharepointroad.com (SPANISH version). All hosted with ASPHostCentral.com

Hope this helps

share|improve this answer
1  
as i said above CA app pool does not need administrative privileges. You should always go for least privileges and dedicated service accounts when setting up security on your farm. The only account that does need local admin rights is your install account technet.microsoft.com/en-us/library/… –  Anders Rask Aug 23 '10 at 21:42
add comment

Have checked all the basic settings but have not looked at trace log. Security event log doesn't show anything.

I uninstalled and did a single server setup to see how that would go and it worked fine installing using the same account however, the app pool gets installed with Network Service and when I change the account to my spinstall account it doesn't work again so I am assuming that there is some sort of permissions that it's missing. Really annoying but not sure where to go. I will try trace log next.

Thanks Any further help is always appreciated

Thanks Matt

share|improve this answer
add comment

Your CA app pool account / farm admin should not need local admin privileges.

That privilege should only be necessary for the install account.

You checked all the basics (spelling etc) and that the account isnt locked out or anything?

Have you checked trace log or security event log for relevant info?

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.