SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a MOSS 2007 site with a document library which uses an InfoPath 2007 form in the browser to collect information from the users. It has a number of views used to group like data elements. The form is rather complex which takes time to fill out. Users do “Save” from the InfoPath form frequently. It has many dropdown list which pull data from list in the site. Additionally, it pulls some data from a database and user detail from AD.

Randomly, users will be presented with an error after they have been filling out the form and try to switch to another view:

"There has been an error while loading the form. A required resource could not be downloaded. To try to resume the download, refresh the page."

If I look in the logs on the server (just one WFE) at the same time I see something like:

08/18/2010 16:25:22.01 w3wp.exe (0x0778) 0x11FC Forms Server Forms Services Runtime 5ajc Medium The Canary has timed out for form

I’ve seen where others have run across this as well but have not found a definitive resolution.

I have tried these:

Adding entry to hosts file

Clearing browser cache

The problem still presents itself almost daily but intermittently. I’m seriously wondering if our corporate network is to blame

share|improve this question
Have you resolved this issue already? Regards, Eric – user13028 Nov 15 '12 at 12:50

It sounds like the session might be timing out in IIS. If the session length is shorter than the time it takes to fill out the form I would expect this type of error. This link has instructions on change the Session Time-out in IIS 7

share|improve this answer

I received a similar error message. See solution here,


As a solution / workaround I had to configure IIS,

  • Change the application pool identity to an Admin User
  • Update the Basic setting of the site to use "Application user (pass-through authentication)" as the Path Credentials
share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.