Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I created a page using SDP added some Data view webparts in and it works fine. But when i try to use Jquery it doesn't work. Any ideas why?

share|improve this question
1  
can you post some of your .aspx code? I'm not sure from your post how you are referencing/using the jQuery library in your page. –  Anonymous Aug 17 '10 at 14:46
    
Right. @Patrick, did you copy the libraries to your server some place, or are you referring to them on a third-party site (Microsoft/Google)? –  Rob Wilson Aug 18 '10 at 2:57
add comment

1 Answer

A few things with this question:

  1. You say if there's a problem using the DVWP without a master page. There is. The master page brings in required tags and references to the SharePoint Object Model that the DVWP needs. You can use a DVWP on a ASP.NET page without a master page, but you still need those references. Just copy the header from a master page to get them.

  2. You say you used SDP to add them. I can only assume you mean SPD (SharePoint Designer). That is the only way to create and add DVWPs to Web Part Pages (which already have a master page association, they're just content pages)

  3. You say jQuery doesn't work. Need more info since jQuery has nothing to do with Data View Web Parts, Master Pages, or SharePoint for that matter.

share|improve this answer
    
Thanks guys. I fixed my problem. –  Patrick Sep 1 '10 at 4:04
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.