Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I am having issues at a client with regards to permissions that I need to request for my account to be able to deploy wsps (using WSPBuilder) to the development environment, and to debug workflows in SharePoint 2007:

As far as I know the following are the required permissions:

  • Farm Administrator
  • Site Collection Administrator
  • Member of the "local Administrators" group on each server in the farm (excluding DB)
  • Member of the DB_owner role on the SharePoint_Config DB and the content DBs for the Central Admin and web applications.

Any other permissions required, or any on this list that are not required ?

share|improve this question
    
Is SharePoint on the same machine that you're running VS on? –  Ryan Oct 12 '12 at 13:27
add comment

2 Answers 2

To debug all you need is to be farm administrator and site collection administrator then attach the debugger and you are ready to go.

RUn as admin vs 2010 or vs 2008

share|improve this answer
    
The problem is that the account they provisioned for me has Farm and site collection admin rights, but when trying to debug it just gives access denied errors in VS 2008. –  MrThirsty Oct 12 '12 at 13:14
    
@MrThirsty So the solution deployed ok? Maybe including a screenshot in your question would help.. –  Kit Menke Oct 12 '12 at 14:12
    
I can't deploy anything either, when I run WSPBuilder to deploy the wsp solution, it says that my account doesn't have installation permissions on the server. trying to debug existing solutions deployed by the previous developer. –  MrThirsty Oct 12 '12 at 14:20
    
Have you tried 'Run as Administrator' on VS? –  RJ Cuthbertson Oct 12 '12 at 14:43
    
I can't "Run as admin" as I am using Win Server 2003, which only gives you a "Run As" option, you need to know the administrator password. Which I do not know. –  MrThirsty Oct 17 '12 at 9:35
add comment
up vote 0 down vote accepted

So it turns out that the system administrators didn't apply the rights correctly at a DB level. We got them to provide the correct rights and I can now deploy and debug.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.