Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I'm using SP2010, and am working at the moment in SPD 2010. I have a site, and am trying use a copy of v4.master as the site master page.

So, in SPD...

(I got two different books on SPD, and they basically describe the process as this)

  • I create a copy of v4.master
  • check it out
  • rename it, leaving the extension as '.master'
  • save it
  • check it back in.
  • right click on the renamed file, and pick 'Set as Default Master Page'*.

So in the browser, I hop over to Site Settings > Master Page, and get "The site master page setting currently applied to this site is invalid. Please select a new master page and apply it" along with a big ol' yellow warning icon. And of course, the renamed master page is not availabe in the select menus for master pages.

  • that last step in my instructions, I've tried 'Set as Custom Master Page', both, and neither. Basically exhausted the boolean possibilities there. No luck.

I'm stumped. I've looked at plenty of posts here, and on stackoverflow. Google has not been kind today, either.

So folks, how do I get my copy of v4.master to be the master page for my site? I'm at a loss.

share|improve this question
add comment

2 Answers

up vote 1 down vote accepted

Master pages need to be approved before use. Between the last 2 steps, you should approve the master page in the browser and then apply it as the default master page in SPD.

share|improve this answer
    
All the approval stuff is greyed out. I logged in with my site collection admin creds, and the approval buttons are still greyed out. Grr. –  Alan M Oct 11 '12 at 22:57
    
I'm accepting PirateEric's suggestion as the answer, but how I achieved it did not fit in the comments. So, I plugged it in as an additional answer, which you should see under the initial question. Maybe. –  Alan M Oct 12 '12 at 0:15
add comment

I would like to thank Pirate Eric for his suggestion, as it put me on the right path.

In the end, the answer invoved not messing with SPD at all. In SPD I deleted the would-be master page I created, and worked entirely via the browser.

Here is what worked for me:

  • In the browser, I go to site collection root > Site Actions > Site Settings > Galleries > Master Pages
  • Check the box for v4.master
  • Pick "Download a Copy" from the ribbon
  • On my workstation, rename the file
  • Back in the browser, I click "Upload Document" in the ribbon
  • I now see my renamed master page in the Master Page Gallery, with "Draft" listed in the "Approval Status" column
  • I click the dropdown next to the Name, and pick "Check Out"
  • After the page refreshes, I click the same dropdown and pick "Check In"
  • I pick "1.0 Major version (publish)" for the Version, and "No" for "Retain Check Out"
  • Hm. Still listed as draft. I do notice there is a "Publish" button available in the ribbon, though.
  • I check the box next to the file name, and click that "Publish" button
  • The page reloads and now the Approval Status reads "Pending"
  • I approve the file, and now the Approval Status reads "Approved"
  • I nav to the site > Site Actions > Site Settings > Master Page
  • And finally, my master page is listed in the Site Master Page dropdown menu. Win!
share|improve this answer
    
That is the same process if you do it via SPD too. Upon check in as a major version in SPD, it will tell you content approval is required via a popup. Click Yes and you get take to the browser to approve the masterpage. –  PirateEric Oct 12 '12 at 0:29
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.