Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I can access my WSS3 server via http://sharepoint, but not http://sharepoint:800, which I require. Ideally I would like both to be accessible. My guess is that there is a conflict between my mappings or between them and the IIS bindings.

What could be wrong with my configuration that is preventing access on port 800? The only way I can access it is using port 80 - either through http://sharepoint or http://sharepoint.company.local.

My alternate access mappings are configured as follows:

Internal URL                   Zone                  Public URL for zone
http://svr:19937               Default               http://svr:19937 
http://svr:800                 Default               http://svr:800
http://sharepoint.company.com  Internet              http://sharepoint.company.com
http://sharepoint:800          Custom                http://sharepoint:800
http://svr                     Default               http://svr

I realize there is no actual "mapping" here. TBH I don't know whether AAM is making any difference / is applicable to my problem.

The IIS bindings are:

Type      Hostname       Port        IP Address
http                     80          *
http                     800         *

I also tried to make it work by extending the application, but it doesn't work - apparently http://sharepoint:800 is already in use. I don't understand how - the site url is http://svr:800. Need help.

share|improve this question

1 Answer 1

up vote 1 down vote accepted

Are you sure that the port 800 has been whitelisted in your firewall on your Windows Server ?

You could also run netstat on the server and make sure that the port 800 is not internally used by something else, preventing thus a proper use for the web application.

Regarding your AAM is

> http://svr:800

an internal url (and thus added as so ?) (because it's added twice to the default zone)

19937 is your central administration right ?

share|improve this answer
    
When the port is in use, your web application in IIS won't start at all. I agree with Francois, your AAM list is confusing. Please make sure you only list the AAM mappings for the web application causing trouble. I also wonder why you would have a need for all these mappings. Usually a single URL with maybe an extend for different authentication methods would do it. I find it best practice to use as little mappings as possible, they only tend to create confusion when used in the wrong way. –  Jasper Oct 10 '12 at 8:06
    
It was the firewall! I used Windows FireWall With Advanced Security (catchy name) to enable the port on the inbound side. Thanks :) –  Black Knight Oct 10 '12 at 21:32

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.