Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

Hi I am using SP2013 stand-alone version. I am trying to deploy a solution in SharePoint 2013, I have successfully added the solution to solution store, but whenever I try to deploy the solution, timer job gets created but the timer job do not deploy the solution i.e. if i refresh the central admin page once it show deploying the solution, but after few mins when i refresh the page, it shows 'not deployed', and i also checked logs for any error but could not find any related to this, I tried PowerShell, STSADM & Central Admin, all with same result (yes i tried force also)

Some extra information -

  • My solution needs GACDeployment, CASPolicies if that matters
  • And my SharePoint Time Zone is different from my computer(which i have not fixed yet), I initially thought error is for this, but I tested with some other timer job to find it is not a problem

Any suggestion? thanks in advance

share|improve this question

1 Answer 1

up vote 0 down vote accepted

I found the solution to the problem, for some reason (I am yet to understand the reason)

stsadm -o deploysolution -name solutionname -url siteurl -allowGacDeployment -allowCasPolicies -immediate 

is not working, in place of -immediate when i used -local (i am using a standalone version so -local does the work for me) i.e.

stsadm -o deploysolution -name solutionname -url siteurl -allowGacDeployment -allowCasPolicies -local

worked like a charm

share|improve this answer
    
For what it's worth, CAS policies are ignored in SharePoint 2013. All assemblies run with full trust: msdn.microsoft.com/en-us/library/jj163902.aspx –  Danny Jessee Jan 7 '13 at 10:52

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.