Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

In my custom page layout there are no borders and captions next to my editable field. I want my editable fields to be displayed like below. Is it OOTB, how can i do that?

enter image description here

share|improve this question
1  
Please refer to this question with the solution here : sharepoint.stackexchange.com/questions/36989/… –  Arko D Oct 9 '12 at 9:09
    
I already saw that post but didnt succeed –  ozdogan Oct 9 '12 at 10:03
    
what part of that process is making the border and caption actually? because the steps you provided is a standard custom page layout development. –  ozdogan Oct 9 '12 at 10:30
add comment

1 Answer

up vote 1 down vote accepted

Firstly what version of sharepoint is this in? Im going to take a guess that this is in 2010.

I think your talking about the chrome properties. In sharepoint 2007 it was easy - siteactions - edit page and select the webpart - edit and change its properties on the right.

For 2010 its slightly different:

How to format RichHtmlField in Publishing site Custom Page Layout

also

http://www.sharepointblues.com/2010/10/27/custom-styles-for-sharepoint-2010-rich-html-field/

and

http://www.bentedder.com/customizing-markup-and-table-styles-in-sharepoint-richhtmlfield/#css

EDIT

You can do it through code:

SPFile file = web.GetFile("SitePages/home.aspx");

SPLimitedWebPartManager lwpm = file.GetLimitedWebPartManager(

                System.Web.UI.WebControls.WebParts.PersonalizationScope.Shared);

SPLimitedWebPartCollection webpartColl = lwpm.WebParts;

foreach ( System.Web.UI.WebControls.WebParts.WebPart wp in webpartColl)

{

                wp.ChromeType = System.Web.UI.WebControls.WebParts.PartChromeType.TitleAndBorder;

                lwpm.SaveChanges(wp);

}

http://social.technet.microsoft.com/Forums/en-US/sharepoint2010customization/thread/9cb91fa0-39e2-4244-aa91-cdb1c27629cb/

or you can do it through sharepoint UI:

Change Web Part Properties in SharePoint 2010

After you select and insert a Web Part into your page, you may want to modify its properties to fit your needs. The number and type of properties you can modify in SharePoint 2010 are based on what type of Web Part you use. When you select the Edit Web Part command by clicking the Web Part menu (in the far right of the Web Part title), SharePoint opens the Web Part tool pane. In some Web Parts, SharePoint creates a link to this tool pane as part of the placeholder text. Following is a list of properties in the tool pane common to List View Web Parts:

Appearance: The Appearance section allows you to title the Web Part, fix the height and width as necessary, and determine the chrome type. Chrome is another word for the Web Part surround; for example, title and border options.

http://www.dummies.com/how-to/content/change-web-part-properties-in-sharepoint-2010.html

shown through pictures :)

https://docs.google.com/viewer?a=v&q=cache:ggVHboEicKIJ:https://www.madison.k12.al.us/departments/instruction/instructionaltechnology/websitewiki/Documents/Website%2520Help%2520Handouts/Setting%2520up%2520a%2520New%2520Web%2520Part%2520the%2520first%2520Time-ChromeType.pdf+&hl=en&gl=uk&pid=bl&srcid=ADGEESga34p4GQE_DJXG4_DH62IOsQlkgsPtazMLbznVYOF_4cWlC69KvpYBCENZOYYsoU-0QDp6YDvVcmScvh-62-x-XgUr-1crcYA9JkSOLlyzhX_eDE4fsQ7SegY6HHS-Vr23NjLM&sig=AHIEtbTh8On2RC7ZLRR6LCGxwiLZrEQcNA

You need to in sharepoint 2010:

1) goto your page that you want to edit.

2) on the ribbon select "page" tab.

3) select edit page within the ribbon (should be on the left hand side)

4) once selected the page will change to edit mode and you can now add webparts to the page. Find your webpart that you want to add the chrome... there should be a drop down arrow on the right handside of the webpart. Click it.. you should see some options. the one you want is "Edit Web Part". Select that option.

5) click "Appearance" in the new tab on the right hand side of the page

6) near the bottom you should see "chrome type". click on the dropdown and change to "Title and border". Now select apply and then ok.

You should now see the changes with your webpart wrapped in a border with title :)

or hover over the webpart and an arrow should appear on the top right side of the webpart, click it and select "Edit Web Part" and follow from 5 above!

hope this helps :)

share|improve this answer
    
I am on SharePoint 2010. By the way, the style in the picture i put in my post, is it OOTB or is it custom css? –  ozdogan Oct 9 '12 at 11:29
    
Its OOTB, you just need to change the setting so that it looks like that! –  ali Sharepoint Oct 9 '12 at 11:53
    
i think i am missing something. exactly what setting makes chrome around editable field? –  ozdogan Oct 9 '12 at 12:31
    
iv ammended my answer :) –  ali Sharepoint Oct 10 '12 at 8:56
    
actually what is on my page layout is NOT a webpart, it is a field(like <SharePointWebControls:TextField FieldName="fa564e0f-0c70-4ab9-b863-0177e6ddd247" runat="server"></SharePointWebControls:TextField>). So there is no edit web part option. –  ozdogan Oct 10 '12 at 11:21
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.