Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

We recently upgraded from Windows Server 2003 to 2008 R2. During our upgrade we accidentally removed IIS and reinstalled it again and now the site can only be accessed locally and if we try to access it externally we have to use the IP address.

So far we have tried the following:

  • Ping the server name my notebook: it is accessible.
  • Ping the server name on the box itself: it is also accessible.
  • Ping the server using the IP Address locally on the box and on my notebook : it is still accessible.

The other thing is that when we use IP address, the site returns repeated logon screens until you click on cancel.

Here is the error we get when try to access it on my notebook.

Not Authorized: HTTP Error 401. The requested resource requires user authentication.

Many thanks, Sepaka

share|improve this question

2 Answers 2

up vote 0 down vote accepted

You might want to look at the authentication settings in IIS7, select the IIS site which hosts your main web application, from the IIS menu select 'Authentication' ensure Windows Authentication is set and then when that is highlighted select 'Advanced' and see if you've got Negotiate above NTLM, if in doubt just use NTLM and remove Negotiate.

share|improve this answer
    
Thank you very much Pigeon. I switched to NTLM only and it worked. –  Sepaka Oct 9 '12 at 7:25

I think you might be missing some settings in iis manager!

can you check out the link below to see that its mapping is configured properly!

http://technet.microsoft.com/en-us/library/cc261814(office.12).aspx

this is for 2007 but 2010 has the same priciples ;)

hope it helps :)

share|improve this answer
    
Thank you for your response AlmostSharePointMaster. –  Sepaka Oct 9 '12 at 7:26

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.