Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I'm involved in upgrading a Sharepoint 2007 server to 2010. Most of it has gone smoothly but I'm stuck on the advanced search. We're using the same advanced.aspx search page as in the 2007 setup but no results show up.

I've got an advanced search box webpart at the top of the page and then a Search Core Results webpart underneath that. All I get in the results web part is "No results are available. Either no query is specified, or the query came from advanced search (Federated Webparts do not support Advanced Search queries).

I've tried the Federated Results webpart and that doesn't display anything either. It stays blank after a search.

Could it be something to do with the 2 Advanced Search boxes on the page? I think the visible one is the second but I can't get access to the first because the web part area it's in seems to be above or under the ribbon now after the upgrade.

Any ideas?

share|improve this question

1 Answer 1

up vote 0 down vote accepted

All is well. Apologies for possibly posting too soon.

I noticed the Advanced Search Box web part that was visible on the page has a [2] beside it so that meant there was another that was not visible. I added ?contents=1 to the URL to view all the web parts and deleted both Advanced Search Boxes then added one back in to a viewable web part area. Works now!

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.