SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a pretty common problem with WSS 3.0

When a user logs on to the site using IE 7/8 and opens a word document from a document library he gets prompted for a login / password. At this point, even when cancel is pressed or when the login window is closed the document still opens.

This problem is document online (and here : Forms Authentication, persistent cookie needed by IE, but not Firefox or Chrome)

The solution is to either :

  • Add the site to the trusted zone (I can't do that, I have a public-facing website so my users come from everywhere)
  • Disable client integration

I disabled client integration (through Central Administration > Authentication Providers) and I still get the problem.

What else do I need to do to disable client integration? Am I missing something? Is there something else I can do to avoid this problem?

share|improve this question
up vote 1 down vote accepted

You can find a HttpModule helping out with this in my blog post Remove Login box when anonymous users download office document from SharePoint Site

Depending on your version of office you may have to extend the list of rejected User Agents in the code.

share|improve this answer
Sorry it took a while to get back to you. This works perfectly. Had not seen this fix when I looked the problem up. Can't say I really understand what's going on though... I presume that if I had the problem with office 2010 I would block MSFrontPage/14.0, is that what you meant? In any case, thank you very much for your help, much appreciated! – Hugo Migneron Oct 4 '12 at 3:03

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.