Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

Inherited the following:

Internal site: http s://nameofsite Default Zone External site: http s://www.nameofsite.com Internet Zone

Navigate to external site, go to doc lib, select doc and attempt to send a link to the document using the send to menu and the correct URL appears in outlook email ex: http s://www.nameofsite.com/sitename/doclib/nameofdoc.docx

Navigate to internal site, go to same doc lib and select same doc and attempt to send a link and I do not get a matching URL.

I'm expecting http s://nameofsite/sitename/doclib/nameofdoc.docx, instead I get http s://www.nameofsite.com/sitename/doclib/nameofdoc.docx

I also have a TMG sitting in front of this as well. Personally, I've done AAM before (maybe with different naming conventions for host headers) but perhaps I have never noticed the send to menu before.

Where do I go for information on this?

I found the following link to help but wondered if I'm missing something. http://techblurt.com/2011/02/21/configuring-sharepoint-2010-alternate-access-mappings-and-my-sites-with-a-reverse-proxy-e-g-tmgisa/

edit: altered the fake URL to get by the URL checker with stackexchange

share|improve this question
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.