Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

On 's home page I've added 2 RSS Viewer web parts. One feed is from a sub-site of this one while the second is to an external site. The internal feed doesn't work, and the external feed does.

The url I used for the internal feed resembles http://mysites/users/myusername/sub-site-name/_layouts/listfeed.aspx?List=111dcdbb%2Dcffb%2D222d%2Db88f%2D3f0da8da999d#, and works in IE.

The error is "The requested RSS feed could not be displayed. Please verify the settings and url for this feed. If this problem persists, please contact your administrator.", which other questions here indicate might be related to authentication.

This sounds about right as access to our sharepoint is managed through using Active Directory accounts, meaning with Internet Explorer we don't have to login while with other browsers we need to use domain credentials.

So how do I get the rss web-part to "stay inside"? Is there a different url syntax I should be using? or a different web-part altogether?

share|improve this question
add comment

1 Answer 1

This is most likely due to Loopback check on the server. This a check Microsoft has introduces into the OS (starting in Windows server 2003 SP1) to avoid a certain kind of attack where a server was tricked into accepting request to other addresses and showing them as safe.

When the server is contacting itself with another name than the servername it'll respond with a 401.1 access denied unless that other name is in a list of safe names in the registry.

Ask your admins to verify that they can't access http://mysite using a browser on the server.

Then redirect them to this KB describing the problem You receive error 401.1 when you browse a Web site that uses Integrated Authentication and is hosted on IIS 5.1 or a later version. They should use Method 1 for solving the problem a better description of the steps can be found at DisableLoopbackCheck. Lets do it the right way

share|improve this answer
    
thanks. I'll follow up with IT and see where that leads –  matt wilkie Oct 1 '12 at 17:02
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.