Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

On I've created a wiki site and would like to make use of , however when I Page > Edit > Insert > Web Part CQWP isn't among the available choices. Does it have another name? or perhaps our administrator hasn't enabled that?

I'm an end user, and the site is running SharePoint Server 2010 (according to Help).

share|improve this question
add comment

2 Answers 2

up vote 1 down vote accepted

CQWP is added to the list of available web parts as part of the Site Collection Feature "SharePoint Server Publishing Infrastructure"

Go to Site Settings | Site Collection Features (in Site Collection Administration group). You may have to click Site Settings | Go to top level site settings to get to the root. In a sub-site there may another publishing feature to activate also.

After that Content Query is available at under Edit > Insert > Web part > Content Rollup.

Or you can save the following xml into a file called ContentQuery.webpart and the add it to your pages using "Upload a Web Part":

<?xml version="1.0" encoding="utf-8"?>
<webParts>
  <webPart xmlns="http://schemas.microsoft.com/WebPart/v3">
    <metaData>
      <type name="Microsoft.SharePoint.Publishing.WebControls.ContentByQueryWebPart,Microsoft.SharePoint.Publishing,Version=14.0.0.0,Culture=neutral,PublicKeyToken=71e9bce111e9429c" />
      <importErrorMessage>Cannot import this Web Part.</importErrorMessage>
    </metaData>
    <data>
      <properties>
        <property name="Title" type="string">Content Query</property>
        <property name="Description" type="string">Displays a dynamic view of content from your site.</property>
        <property name="ChromeType">TitleOnly</property>
        <property name="ChromeState">Normal</property>
        <property name="ItemLimit" type="int">15</property>
        <property name="SortBy" type="string">{8c06beca-0777-48f7-91c7-6da68bc07b69}</property>
        <property name="SortByDirection" type="Microsoft.SharePoint.Publishing.WebControls.ContentByQueryWebPart+SortDirection,Microsoft.SharePoint.Publishing,Version=14.0.0.0,Culture=neutral,PublicKeyToken=71e9bce111e9429c">Desc</property>
        <property name="GroupStyle" type="string">DefaultHeader</property>
        <property name="ItemStyle" type="string">Default</property>
        <property name="ServerTemplate" type="string"></property>
      </properties>
    </data>
  </webPart>
</webParts>
share|improve this answer
    
thanks! Since I was working on a sub-site I needed to Site Settings > Go to top level site settings, activate "SharePoint Server Publishing Infrastructure", followed by sub-site Settings > SharePoint Server Publishing [activate]. –  matt wilkie Sep 27 '12 at 18:05
add comment

You need to enable the publishing infrastructure feature for the site for the CQWP to show up.

share|improve this answer
    
under Site Settings > Features I see "SharePoint Server Publishing", is this what you mean? In any case when I press the [activate] button I'm told "The feature being activated is a Site scoped feature which has a dependency on a Site Collection scoped feature which has not been activated. Please activate the following feature before trying again: SharePoint Server Publishing Infrastructure", which sounds like an Admin-only thing. Is that correct? –  matt wilkie Sep 27 '12 at 17:50
    
It's a Site Collection Admin only thing, but on mysite you should be Site Collection Admin –  Per Jakobsen Sep 27 '12 at 18:04
    
Got it now, see comment on other answer. I had started on a sub-site instead of my root my-site. Thanks for the help. –  matt wilkie Sep 27 '12 at 18:11
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.