Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I use this command:

SPMetal /web:http://intranet.contoso.com/sites/Lab05 /code:Entities.cs /language:csharp 

for creating the entity file Entities.cs, but I get the error:

Must specify source code language..

But I have specified the source code language, so what's wrong?

share|improve this question
    
Have you tried to leave out the /language parameter? It isn't required when you /code ends with .cs. Have you tried to use - instead of / in front of parameters? –  Per Jakobsen Sep 26 '12 at 18:45
add comment

1 Answer

The error is not because of /language or - parameter. I need to put one space at the end of every parameter and it solves the problem after getting one warning message.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.