Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I'm installing Sharepoint Server 2010 and before that it requires prerequisites to install. It is skipping the installation of KB976462 & KB974405 (which I tried installing seprately but no luck) plus I have restarted the machine several times but the Application Server Role, Web Server (IIS) Role is throwing some configuration error.

Below is the summary of prerequisties

Application Server Role, Web Server (IIS) Role: configuration error - pending restart of the computer
• Microsoft SQL Server 2008 Native Client: was already installed (no action taken)
Hotfix for Microsoft Windows (KB976462): Installation skipped
Windows Identity Foundation (KB974405): Installation skipped
• Microsoft Sync Framework Runtime v1.0 (x64): equivalent products already installed (no action taken)
• Microsoft Chart Controls for Microsoft .NET Framework 3.5: was already installed (no action taken)
• Microsoft Filter Pack 2.0: equivalent products already installed (no action taken)
Microsoft SQL Server 2008 Analysis Services ADOMD.NET: Installation skipped
• Microsoft Server Speech Platform Runtime (x64): Installation skipped (optional component)
• Microsoft Server Speech Recognition Language - TELE(en-US): Installation skipped(optional component)
• SQL 2008 R2 Reporting Services SharePoint 2010 Add-in: Installation skipped (optional component)

The installations marked bold are behaving in an unexpected way.

Please guide

Thanks

share|improve this question
    
Any comments???? –  Romil N Sep 22 '12 at 5:03
    
What operating system are you using? Sounds like your application server role is in a corrupt state. Can you try to configure it manually and see if that gets you any further? –  Derek Gusoff Sep 22 '12 at 16:44
    
I am using Win Server 2008 R2. I have tried configuring manually as well as using prerequistie file too. is just DOESN'T WORK!!! Plus the hotfix say that "there is no update available for the selected computer" I am using x64 machine –  Romil N Sep 22 '12 at 17:44
    
When I'm tryn to install Hotfixes it says that the "The update is not applicable to your system". Error can be view at imageshack.us/a/img145/1180/sphotfixerror.png –  Romil N Sep 25 '12 at 17:38
    
your machine is misconfigured ('hosed') somehow. You need to either fix the problem or rebuild the machine from scratch and start over. –  Derek Gusoff Sep 25 '12 at 20:05

1 Answer 1

I fixed a similar issue by ending the IIS-ManagementService (? - in German IISVerwaltungsdienst) and WWW-PublishingService befor the Setup.

I guess, that the "Installation skipped" notifications just say, that the Setup didn't try because of the other error.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.