SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a column type 'multiple lines of text' and selected ‘Append Changes to Existing text'. On the default display/edit forms the data shows up as expected.

I then needed to alter the form so fire up SPD and create new forms, don’t make any changes to the form but make it default. However when the new form is rendered the data from this particular field is missing. What can be wrong and whats the resolution ?

UPDATE: When a Display newform is created in SPD a 'Data View Webpart' is added automatically. This is the line I think thats causing the problem :

 <xsl:value-of select="@Body" disable-output-escaping="yes"/> 

The Body is the original column name which I changed to 'Milestones later.

Cant find anything on the net that seems to work, any ideas ?


share|improve this question

I tried this before but didnt work, on 2nd attempt it worked..must have missed something 1st time round ..

share|improve this answer

You can try replacing this line:

<xsl:value-of select="@Body" disable-output-escaping="yes"/>


<SharePoint:AppendOnlyHistory FieldName="Body" runat="server" ControlMode="Display" ItemId="{@ID}"/>

ControlMode can be changed to Add or Edit as per requirements

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.