Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I am little confused about how SSL works in SharePoint. We have a portal site (say portal.abc.com). I need to enable SSL on this web application (http://blogs.msdn.com/b/sowmyancs/archive/2010/02/12/how-to-enable-ssl-on-a-sharepoint-web-application.aspx).

After reading the article I became little confused. Will I be able to access same site without SSL? for example, current internal users access the site with http://intranet.company.com. I want both http://intranet.company.com and https://intranet.company.com to be up and running.

Please share any goodies that I need to keep in mind during ssl setup for sharepoint webapp.

share|improve this question
    
In IIS you can redirect responses over HTTP port 80 to HTTPS port 443 to ensure SSL is used. –  RJ Cuthbertson Sep 20 '12 at 13:53
    
rjcup3: I modified the post. it was little vague before. –  Maria Burton Sep 20 '12 at 13:56
    
I followed this post ashrafhossain.wordpress.com/2011/06/27/… on extending existing web app. After creating the web app I dont see the newly extended web app in the web application list. But it is listed in AAM page. I see 2 entries here for the web app. intranet.company.com default same for public url. the 2nd entry looks like extranet.company.com zone extranet public url same as https//extranet.company.com –  Maria Burton Sep 20 '12 at 14:53
    
You won't see it under Manage Web Applications. You'll only see one entry for both zones. –  RJ Cuthbertson Sep 20 '12 at 15:03
add comment

1 Answer 1

up vote 0 down vote accepted

You can use both HTTP and HTTPS. Just set up both as public URLs for your web application's respective zones.

For example:

If you extend a web application to the extranet zone, you can keep the public URL of the default (or intranet) zone as http://intranet.company.com. The public URL of the extranet zone would be https://intranet.company.com. Then you can open up port 443 to the outside world, but make sure that port 80 is secured for internal use only.

It is generally easier from an end user perspective to set up a different host header for the extranet (like https://extranet.company.com/) and redirect all HTTP requests using that host header to the HTTPS site to ensure external users are using a secured connection without relying on them to remember https:// every time. Also, if you have your HTTP site closed to the outside world, without setting up something to push external requests to HTTPS your end users will not be able to access the site over HTTP and the site will appear to them to be down if they type http://.

share|improve this answer
    
cool. I did exactly what you proposed. I used extranet in the header. However, newly extended web app does not show up in the web app list. but listed in the AAM screen. Normal? –  Maria Burton Sep 20 '12 at 15:04
    
You won't see it under Manage Web Applications. You'll only see one entry for both zones. –  RJ Cuthbertson Sep 20 '12 at 15:05
    
also, I opened IIS > selected the new webapp > click on SSL Settings > and server certification is missing. (i went to SSL settings and checked "Required" and left "ignore" selected for client certifications. –  Maria Burton Sep 20 '12 at 15:07
    
I added certificate thru IIS > sites> bindings > edit > selected an cert. Now it's all fine. Thanks –  Maria Burton Sep 20 '12 at 15:32
    
No problem. Glad to help. –  RJ Cuthbertson Sep 20 '12 at 15:44
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.