Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

Our intranet is on SharePoint 2010. Many employees are beginning to download IE9 and try logging on from home to our network. Users have to logon with a security token and I believe we use Juniper.

IE9 is throwing a popup message that says "Display Mixed Content?". I have directed our help desk to walk the users at home through changing the settings on their computer via the internet options.

Our help desk dept is now saying that although this is fine for a workaround we need something more permanent. How do I accomplish this. Security and infrastructure is way over my head.

Thanks, Ninel

share|improve this question

2 Answers 2

Mixed content means that you are watching the page A. Over https and you have elements from source, or B. Over http and you have elements from https

By elements I mean javascripts, images, ...

What I would do is to see the page source from IEmand look for http or https. This helps you identify which where is the mixed content (masterbpage, page or content) and I would change all those links to server-relative (e.g. /your-subweb/your-image.gif)

share|improve this answer
    
I just ran Fiddler on the main landing page of our intranet and I am seeing a call to www.google-analytics.com. Could this be the problem? Does it make sense for an intranet site to need google analytics? Would it be enough to change the url to google-analytics.com? –  ninel Sep 19 '12 at 20:17
    
Gomiunik, This is the actual code in one of our master pages: '(function() { var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true; ga.src = ('https:' == document.location.protocol ? 'ssl'; : 'www') + '.google-analytics.com/ga.js'; var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s); })();' Would this work? –  ninel Sep 19 '12 at 20:35
    
The best way to verify is to comment out the code. I also wouldn't use google analytics on an intranet site. You also have alternatives like iis log analyzers, sharepoint's built-in usage reports,... –  Gomiunik Sep 20 '12 at 20:37

The problem is you probably have a load balancer in front or juniper itself is acting as a load balancer so it is ssl from browser to load balancer/juniper and http from load balancer to web server, so the request is actually recieved as http and that code interprets it as such and calls google analytics over http. We had a similar problem with juniper.

The easy fix is just force the call over https/ssl in the code, since an http page calling https does not trigger the mixed content message.

Alternatively you could set up different zones and render the http/s protocols based on the fqdn URL used to access the site if you don't want to take the internal performance hit of calling ssl when you don't have to.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.