SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I accidentally tried to enable a web app solution on the central admin web app. It errored and did not enable. I closed CA and now when I try to open I get an unexpected error when traced points to a feature that is in the solution I accidentally tried to enable.

How can I undo this mistake?

share|improve this question
what exactly is the error – Mathematics Sep 19 '12 at 7:32

You can Retract and Uninstall SharePoint Solution via Powershell by going to this link


can also uninstall-all-sharepoint-2010-solutions-via-powershell/ if you don't know which solution you installed but its not recommended

or you can retract solution using STSADM by going to this link and then delete it by going to this MSDN article

share|improve this answer
I tried manually retracting and deleting the solution. It seems that when the feature tried to enable on CA it partially installed parts of the feature even though the feature errored and stopped. Is there a way to see or undo recent changes to CA files, or to revert CA to its factory setup? – SystemAccount Sep 19 '12 at 13:34
up vote 0 down vote accepted

I tried manually retracting and uninstalling. Neither worked. What happened is part of the feature I attempted to enable had already started to change the CA masterpage and css. To fix this we had to work through all of the errors so the feature could deploy and then deactivate and retract.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.