Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I have a top-level team site at http://sharepoint and an enterprise search center site at http://sharepoint/sites/search. There is an alternative access mapping for the web application - sharepoint.int.company.com.

I'm finding that using the normal search field of the team site results in the site sending the user to http://sharepoint/sites/search/Pages/results.aspx?k=marketing&cs=This%20Site&u=http%3A%2F%2Fsharepoint. This page doesn't return any results. If I manually change the URL so that 'u=sharepoint', or the 'u' parameter is completely removed, and I refresh the page, then the search page returns results.

How can I update the team site so that is doesn't pass the 'u' parameter across to the search center?

share|improve this question
add comment

2 Answers

If sharepoint the name of your application pool you could try to add the url to access mappings.

share|improve this answer
add comment

You will need to configure the search box from the Site Collection > Site Settings > Search Settings page. Enable Custom Scopes and select the dropdown mode Do not show scopes dropdown, and default to target results page. These settings are, however, only available with SharePoint Server search features enabled on the site collection.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.