Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I imported user photos to the thumbnailPhoto Active Directory attribute. I ran a full user profile synchronization. Then, I ran the Update-SPProfilePhotoStore PowerShell command as described here. Also, "show in the profile properties section of the user's profile page" is checked.

The photos appear in the user profiles and the organization browser, but not in the People Search results.

I'm running SharePoint Enterprise 2010 with the February 2012 CU.

How can I make the photos appear in the search results?

share|improve this question
1  
Have you checked Managed Properties (Groups > People > PictureUrl) to see if it is configured correctly. –  Hugh Wood Sep 13 '12 at 16:48
    
Thanks, this solved it. To clarify for anyone who may not know where the setting is, it's in application management > manage service applications > search service application > metadata properties > categories > people > people:pictureurl –  LCountee Sep 13 '12 at 18:52
    
@Hugh Wood You should turn your comment into an answer so that LCountee can accept it and so that people will see that an accepted solution has been found. –  skeletank Sep 27 '12 at 13:59
add comment

1 Answer

up vote 1 down vote accepted

As per my comment,

Go to Central Administration > Application Management > Manage Service Applications > Search Service Application

Click Managed Properties and go to Groups > People > people:pictureurl and configure in here.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.