SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have 2 site collections and I am trying to configure send to connection from site 1 to site 2. Site 1 is in UK SharePoint farm and site 2 is in US SharePoint farm. I've tried creating a send to connection from UK central admin to US central admin and I am receiving "Verification Failed: URL is not a valid routing URL" and ULS logs shows below errors

System.ArgumentException: Verification Failed: URL is a not a valid routing destination

at Microsoft.SharePoint.ApplicationPages.OfficialFileAdminPage.AddorUpdateConnection()

at System.Web.UI.WebControls.Button.OnClick(EventArgs e)

at System.Web.UI.WebControls.Button.RaisePostBackEvent(String eventArgument)

at System.Web.UI.Page.RaisePostBackEvent(IPostBackEventHandler sourceControl, String eventArgument)

at System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)

and

Url validation failed for Servername:portnumber/site /_vti_bin/OfficialFile.asmx during Record and document center connection configuration with exception The request failed with HTTP status 407: Proxy Authorization Required.:

at System.Web.Services.Protocols.SoapHttpClientProtocol.ReadResponse(SoapClientMessage message, WebResponse response, Stream responseStream, Boolean asyncCall) at System.Web.Services.Protocols.SoapHttpClientProtocol.Invoke(String methodName, Object[] parameters) at Microsoft.SharePoint.OfficialFileSoap.GetServerInfo() at Microsoft.SharePoint.ApplicationPages.OfficialFileAdminPage.<>c_DisplayClass2.b_0() at Microsoft.SharePoint.SPSecurity.<>c_DisplayClass4.b_2()

at Microsoft.SharePoint.Utilities.SecurityContext.RunAsProcess(CodeToRunElevated secureCode) at Microsoft.SharePoint.SPSecurity.RunWithElevatedPrivileges(WaitCallback secureCode, Object param)

at Microsoft.SharePoint.SPSecurity.RunWithElevatedPrivileges(CodeToRunElevated secureCode)

at Microsoft.SharePoint.ApplicationPages.OfficialFileAdminPage.IsValidUriToRouter(Uri uriToValidate)

Any help would be appreciated.

Thanks

share|improve this question

Fixed.. by adding proxy settings in central system web.config..

<defaultProxy> 
  <proxy proxyaddress="SiteURL:PortNumber"; bypassonlocal="true" /> 
  <bypasslist> 
    <add address="SiteURL\.com$" /> 
  </bypasslist> 
</defaultProxy>
share|improve this answer
1  
Please can you give sample from your config file and mark as accepted answer. Thanks. – SPDoctor Sep 14 '12 at 16:13
    
<defaultProxy> <proxy proxyaddress="SiteURL:PortNumber"; bypassonlocal="true" /> <bypasslist> <add address="SiteURL\.com$" /> </bypasslist> </defaultProxy> – nishtha Nov 9 '12 at 15:58
    
Can you mark this as the accepted answer, please! – Benny Skogberg Jan 12 '14 at 8:22

Enable the Content Organizer feature on the Record Center/Document Center site and try again. That worked for me. Check here for details:

https://angler.wordpress.com/tag/url-is-not-a-valid-routing-destination/

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.