Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I am using the Business Connectivity Services in SharePoint 2010 to display the content of a database table in an External List on my site.

One of the fields in the database table is of int type and so is mapped by BCS to an integer. As is standard for SharePoint the number is rendered on the display (and edit) forms using the thousands separator (i.e. "1234" is displayed as "1,234").

It is desired that this field be rendered without using the thousands separators but I cannot determine a way to get this to happen.

I would usually make a calculated field that returned the number as a string and use this on the display form, but as this is an external list I am unable to add new fields.

How can I have integer fields in external lists render without the thousands separator on display forms?

share|improve this question
1  
The way SharePoint render these fields is based on Locale, have you considered changing this? –  eirikb Sep 13 '12 at 8:32
    
Is there a way to edit the thousands separator for a locale (even though that's a bit nasty) -- there's nothing evident to me? I do rely on other regional settings being correct for a specific locale, though, so I am loath to mess around too much with the locale settings. This approach would remove the thousands separator across the whole site (which in this instance is not a problem, but is probably the wrong approach in the general case). –  McSharePoint Sep 13 '12 at 9:39
add comment

1 Answer

(If you are using designer) It's in the xslt dataview in SharePoint designer, select the field you are formatting for the output and un-check "Use 1000 separator".

[edit] But you said edit forms as well so I am probably totally misunderstanding you.

share|improve this answer
    
Indeed this should work for views (interestingly the default views created in the external list don't use the thousands separator at all). As you noted in you edit, though, I am looking for the same effect on the list's forms. –  McSharePoint Sep 13 '12 at 9:16
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.