Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I've tested this before, but I can't seem to get it to work again.

I've got a Doc library with webpart pages. Create a new page and in SPD add a CustomListForm to a custom list in display mode. I change the parameter from Querystring ID to Querystring MyID for ListItemID. But it does not work. Displays nothing. Place the page under the list folder and it works great, but only with ID query string. Am I missing a step here. Do I need something else to be able t use a custom query string? I'm only doing this as ID= is giving other problems with some items not displaying.

Alternatively, Also wondering, if I must have my list forms under the list folder, is there any way to lock down/secure custom folders and pages under a list folder that I create? Say I've got users that can write to a list, but I don't want them running a specific custom page under the List folder. How can I do that.

share|improve this question
add comment

1 Answer

You really got two questions here, but I'll take a stab at 'em both.

1.) Your misery sounds very similar to what I've experienced with forms and Related Lists. That ID= parameter is frustrating. I've found the fix to be to use sp2010-related-list-prefill to get that ID to populate correctly. As for the ID param interfering with display of other items on the page, all I can say is I feel your pain. Personal suffering led me to accept that although you can twist ID into MyID, getting SP to accept it when it's looking for ID is just a miserable time sink. It might be more productive to figure out why the other bits aren't displaying right. Or maybe that sp2010-related-list-prefill Just Works, and you get on with life.

2.) Locking down permissions so a group of folks have write to a list, but not more; I asked a similar question last week. The answer is to create a custom Permission Level at the site collection root. (root) Site Settings > Users & Groups > Site permissions > Permission Levels. If you create a custom permission level for your list, you can then combine it with a SP group to get that sort of granularity you are seeking.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.