Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

On WSS 3.o I have created an out-of the box Discussion Board called 'dd'. I need to Cusomize the NewForm.aspx. As noted in numerous online articles I deleted the existing ListFormWebpart and inserted a new DataFormWebpart based on the discussion Booard. I didnt Modify the DataFormWebpart in any way.

I save the Newform.aspx, browse to the Discussion Board and create an Item with Subject 'Test'. All is good. But when I go to create a second Item With A subject of 'Test" I get an error saying 'A Folder with the name Lists/dd/Test already exists.

If I use the DataFormWebpart I am allowed to create discussions with the same name , but if I switch to A DataFormWebpart I am not.

Is this a known issue? Are there any work-arounds?

Thanks

share|improve this question

1 Answer 1

It looks to me here that you have your list new item page linking to the new folder page, so when you try creating a item its actually creating a folder (which is another item based on the folder content type).

To check this

  • Open SharePoint Designer
  • right click on your list and select properties
  • In the List Properties dialog box, click the Supporting Files tab.
  • Ensure that the content type its set to item and not folder for your new form.

Hope this helps

Renzo

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.