Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

3 to 4 document library's got accidently deleted. I restored the content DB however, after restoration I encountered the following issue:

Root site collection ("/") not available on the restoration. All other site collections are listed in the CA.

Are there any powershell or stsadm commands to assist in making the root site collection available, if the root site is missing on the restoration. Is there any possiblity, of getting the root site collection visible through central administration.

Note: i'm sure that, i have restored the correct content DB.

share|improve this question
    
How did you accomplish this restore? Did you restore only the single content DB, or all the content DB's? You have to mount the content DB with the root site first, before other content DB's. –  Jesus Shelby Sep 9 '12 at 21:38
add comment

1 Answer 1

Yeah i had the done the restoration for particular content DB and tried mounting,which also results successful but the issue didn't get fixed.

Resolution :

In central administration --> Choose backup and restore--> Point to recover the data from unattached content database --> give the server name and DB name. Choose browse content/export site or list. Then export the file (*.cmp). After exporting, the *.cmp can be imported. Then restore the document libraries using stp as a usual format.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.