Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

When I visit my local SP2010 instance on Windows 7 at localhost/_vti_bin/listdata.svc I get Internet Explorer cannot display the webpage. There's no details even though I've turned off Friendly errors in IE9 and have the web.config set as <customErrors mode="Off" />.

I attempted to create a Console application with VS2010 and add a service reference. I get the following error:

There was an error downloading 'localhost/_vti_bin/listdata.svc'. The operation has timed out Metadata contains a reference that cannot be resolved: 'http://localhost/_vti_bin/listdata.svc'. The HTTP request is unauthorized with client authentication scheme 'Anonymous'. The authentication header received from the server was 'Negotiate,NTLM'. The remote server returned an error: (401) Unauthorized. If the service is defined in the current solution, try building the solution and adding the service reference again.

Note: a separate port 16xxx instance works fine. It isn't working on port 80.

share|improve this question
    
Did you setup the correct security in the client proxy? –  Steve B Sep 7 '12 at 15:17
    
I am very new to this, so No. I am not sure where do this. –  Sean Sep 7 '12 at 15:31
    
basically, you will have to update the app.config to to make the app match the server authentication requirement. Please update your question to show the content of the app.config. You can also read my blog article that shows a WCF client configuration for SP 2007. This should be identical. It's in french, but I can past relevant portions in english when you'll have posted your configuration file. –  Steve B Sep 7 '12 at 15:48
    
Thanks for responding. I have just begun to create a console app. No app config file exists I'm afraid. –  Sean Sep 7 '12 at 16:04
    
if you created a service reference, you have an app.config. Otherwise this won't work. –  Steve B Sep 7 '12 at 16:52

3 Answers 3

up vote 1 down vote accepted
  1. You need to disable the Loopback check if you're running SharePoint locally (see here http://support.microsoft.com/kb/896861)
  2. Follow this for more detailed step by step how to configure http://social.msdn.microsoft.com/Forums/en/wcf/thread/021babc6-2009-4ed9-81f4-ac48cc300c94?prof=required
share|improve this answer
    
I will give this a go. Thanks very much. –  Sean Sep 7 '12 at 17:35
    
Not having much luck mate. I am able to view localhost:66XXX/_vti_bin/listdata.svc still, but can't hit the one on port 80. The web.config to edit is: Web Server Extensions\14\ISAPI\web.config - right? –  Sean Sep 7 '12 at 18:34
    
in your external application –  C. Marius - MVP Sep 9 '12 at 17:06
    
This took a while and I kept coming back to it. I did use the DisableLoopBackCheck Reg DWORD and it seems to have worked for me. I only recently rebooted and everything works for this now. Cheers. –  Sean Sep 26 '12 at 14:35

There are so many links on this and none of them helped. I was being blocked by a permission issue when accessing /_vti_bin/listdata.svc. I had to go into Component Service and give the NETWORK SERVICE Access permissions under the COM Security Tab. I also gave Launch Permissions to keep from messing around. This is on a DEV box. I will give this more attention when in Production.

share|improve this answer

Try this , hope it helps Use PowerShell to allow Anonymous Access to GetItems

share|improve this answer
    
Thank you. I will read over this. –  Sean Sep 7 '12 at 21:00

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.