SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

After restore the content db from xxx environment to yyy environment.

  1. create web application

  2. add content DB(we mapped to restored db).

  3. sites not up. shows 404 error occurred

  4. view site collection, found the toplevel site collectio ins missing(i mean "/")

Please any1 help me on this. where went wrong ?

share|improve this question
maybe the World Wide Web Publishing Service is not activated? – Remko Sep 7 '12 at 7:15

Not sure if restoring content DB clears configuration cache as well for that specific Content DB,

You can follow this blog who had similar kind of problem and he solved it by clearing cache.

Similar kind of problem solved in this question by a different way.

Also can you go to following pages for your top site collection that you said you can view and check ULS Viewer to find any errors come up

  • /_layouts/settings.aspx
  • /_layouts/create.aspx


Another Problem can be if any pages or content is corrupted e.g. "default.aspx" as explained in this Blog

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.