Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

A separate group of IT personnel own the farm on which they are migrating from SharePoint 2007 to 2010. I have a production site that I have been building for the last two years. In particular, there is one list that has approximately 7,900 records already in the list. The list view threshold is set to the default of 5,000. I have done about three weeks of reading on anything Microsoft in effort to resolve this issue. I have attempted to execute every recommendation that I have extracted from this research. These executions include:

  1. creating a new list view complete with filter(s) to reduce the results to way less than 5,000. While the .aspx page will return the desired results, the minute I bring the list into a web part on a page and redirect the web part view to the new list view, that damnedable threshold error message is ALWAYS the result.

  2. creating an indexed column - I have gone through the list settings, click on the Indexed Columns-->create a new index-->set the primary index with no secondary-->clicked the create button. RESULT: that damnedable threshold error message.

  3. created a query that resulted in that damnedable threshold error message.

Since I don't own the farm, I cannot do anything at the farm level. The only other tool available to me is SharePoint Designer 2010.

Is there ANYone out there that can provide a real answer to this problem?

(I gotta tell ya Microsoft, I understand why you incorporated the threshold, but I think it is one of your dumber ideas if the error is thrown because the query has to sort through more than 5000 records. What is the point of having the ability to have a large list if everything one does throws that damnedable threshold error message???) Yes, I am MORE than frustrated!!!

share|improve this question
    
Is it necessary to display large list? If not I would create views based on filter. –  Maria Burton Sep 6 '12 at 20:09
    
@MariaBurton the issue is not just about creating views, it is also about using them, and about using other list settings. –  Christophe Sep 7 '12 at 1:29
add comment

1 Answer 1

You need to have higher permissions in order to create an Indexed Column on a list with more than 5000 items so you would have to ask the admins to create the indexed column for you. However, once the index is created and it is the first field in your filter, it should work for you. At least initially.

A better option would be to have the Farm Admins enable the 'Daily Time Window for Large Queries' to some off-peak time (i.e. 5pm-7pm). This effectively disables large list throttling for that web application during that window. Not only would this allow you to view the list as you did in SP2007, but it should also let you create those indexed columns as needed, without requiring an admin.

Incidentally, the videos at that link are a fantastic resource for understanding the various options available for handling large lists in SP2010.

share|improve this answer
    
I second Dave's suggestion on those videos. The best resource I have found that explains things. Here is another link that describes how it works: office.microsoft.com/en-us/sharepoint-server-help/… . Note that it is not enough to just create views and indexes. The View queries must be configured to query on the indexed columns first, so the order you specify your filtering is important. Alternatively, create some folders. –  Brian Sep 6 '12 at 21:09
    
+1 very useful, thanks! –  Christophe Sep 6 '12 at 21:33
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.