Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

First I had a plain Team Site without the Feauture "SharePoint Server Publishing" activated. I created several Site Pages, all rendered automatically without the annoying "Recently Modified".

When I activated the "SharePoint Server Publishing"-Feature all my pages now show the "Recently Modified" in the Quicklaunch. Even after Deactivating the feature, the damage is done.

What is the connection between those two things, so I can cut it off?

EDIT: Unfortunately neither do I have control over the site collection nor do I have access to the filesystem. The question is: How do I get back to the state of "not having 'Recently Modified' in my Quicklaunch" by default, (without making changes to the site collection, the filesystem or the masterpage and without Visual Studio)?

share|improve this question
add comment

2 Answers

I hope this explains it for you in detail, it shows you how to hide/disable without effecting other features :)

http://johndandison.com/blog/post/2010/01/25/Removing-the-e28098Recently-Modifiede28099-from-the-Quick-Launch-e28093-SharePoint-2010.aspx

EDIT

Go to "Program Files\Common Files\Microsoft Shared\Web Server Extensions\14\Template\DocumentTemplates" .

Open "wkpstd.aspx" file. Search for tag "SharePoint:RecentChangesMenu". Add visible="false" at the end of this tag. Save this file & refresh SharePoint site .

http://sharepointgauravgoyal.blogspot.co.uk/2011/04/hide-recently-modified-items.html

appart from changing the above or masterpage or css then off the top of my head you would probable need to create a feature that would be farm scoped or web scoped that does the above for you :)

hope it helps :)

share|improve this answer
    
Thanks for the reply - I knew the css snippet to get rid of it from single sites via a form-webpart or the masterpage. Unfortunately it doesn't solve the issue, as nobody wants to modify each website because editing the masterpage in my case is no option. –  curmudgeon Sep 6 '12 at 14:01
    
iv ammended my question for you :) –  ali Sharepoint Sep 6 '12 at 14:32
    
it's a shame I can't access the fs here... I didn't use development tools to get into this problem, just the feature - so now I am looking for a way out of this on the same path ;) –  curmudgeon Sep 6 '12 at 14:51
add comment

Find "wkpstd.aspx" file in 14\template open that up and find the "SharePoint:RecentChangesMenu" server control and then simply add visible=”false” save changes to file and refresh your page and it will work as it worked for me once.

I think your confuse by what this feature does so I would recommend you read this Blog

EDIT

Sorry but I don't think you can do it

without making changes to the site collection, the filesystem or the masterpage and without Visual Studio

share|improve this answer
    
Unfortunately I can't access or manipulate the fs. The blog post is interesting, though I didn't find any hint which aspect triggers the "Recently Modified" thing. –  curmudgeon Sep 6 '12 at 14:50
    
upload a new master page if your current one isn't customized :) since you can activate features I guess you can upload master pages as well ;) –  SharePointer Sep 6 '12 at 15:07
    
that's the first thing which came to my mind as well ;) but editing the masterpage is prohibited, too. –  curmudgeon Sep 6 '12 at 15:15
    
lol is it customized or default sharepoint master page? –  SharePointer Sep 6 '12 at 15:20
    
it is customized –  curmudgeon Sep 6 '12 at 15:22
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.