SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

(Any\all answers to this post are assumed to begin with a "serves you right", so sarcasm is not necessary.. unless it helps you prove your point)

OK, so I just installed SharePoint 2010 on our new web server. Once complete, I received the directive that we shouldn't have our IIS webroot on our OS partition. As such, I found a handy-dandy blog post to move the IIS web root. All worked as expected, and my SP site even responded without any issues.

Then, I tried to start customizing my MasterPages, only to start receiving errors on attempting to render the controls. I found that my MasterPages can't resolve the web controls based on the tag prefix references:

<%@ Import Namespace="Microsoft.SharePoint" %>
<%@ Register Tagprefix="SharePoint" Namespace="Microsoft.SharePoint.WebControls" Assembly="Microsoft.SharePoint, Version=, Culture=neutral, PublicKeyToken=71e9bce111e9429c" %>
<%@ Register Tagprefix="WebPartPages" Namespace="Microsoft.SharePoint.WebPartPages" Assembly="Microsoft.SharePoint, Version=, Culture=neutral, PublicKeyToken=71e9bce111e9429c" %>
<%@ Register TagPrefix="wssuc" TagName="Welcome" src="~/_controltemplates/Welcome.ascx" %>
<%@ Register TagPrefix="wssuc" TagName="DesignModeConsole" src="~/_controltemplates/DesignModeConsole.ascx" %>
<%@ Register TagPrefix="wssuc" TagName="MUISelector" src="~/_controltemplates/MUISelector.ascx" %>

From there, I found yet another handy dandy blog post indicating taht I need to run some PowerShell commands as well, however, every attempt to do so yells at me, telling me that the term new-object Microsoft.SharePoint.SPSite is not recognized. Its almost like all references to the SharePoint objects are unrecognized on my server.

And so now I have quite the quandary. How do I update SharePoint to understand where my "14 hive" is? Shuold I just re-install SharePoint completely, now that IIS is configured to use my other drive as the default Inetpub? Has anyone installed SharePoint to a separate directory before, and perhaps can provide some tips? Please help!

share|improve this question
I understand moving IISWebRoot, but they made you move the 14 hive too? – Dave Wise Sep 4 '12 at 20:57
Thanks Dave. As of this time, the 14 hive is as is, just the sharepoint webroot is on a diff drive now, rather than c:\inetpub, its now e:\inetpub – ewitkows Sep 5 '12 at 12:54

The IIS web root and the SP '14' root are different things. If you want to pursue this it would be helpful to clarify whether you moved one or both.

Either way, in my opinion it's likely best to repair/reinstall SharePoint. This will probably take the least (total) time and yield the most reliable farm.

share|improve this answer
Thanks Jason. I only moved the IIS web root, I didnt touch the '14' root at all. I also tried removing the server from the farm, and then re installing, but it still installed everything to the "C:\Inetpub", not my new location Inetpub. – ewitkows Sep 5 '12 at 12:40
up vote 0 down vote accepted

First, thanks to everyone for the help.. and also for not implicitly saying "serves you right" :)

Secondly, this issue is solved based on a few reasons, most notably that Im a dumb-butt

  1. I completely un-installed SharePoint on the server, just to clear out any open ended problems my tinkering may have caused.
  2. I then re-installed SP and added it back to the server farm (my databases are in a SQL hosted environment)
  3. When re-installing, I found a second tab during the install process allowing me to specifiy file locations, per this handy dandy blog
  4. After installation, I then ran the powershell commands referenced from this blog post, but noticed that there is no space between new-object and Microsoft in the line "new-objectMicrosoft.SharePoint.SPSite(“web application URL”)"
  5. From there, I ran the MoveIIS bat file and pointed my IIS Web Roots to my other partition
  6. Finally, I opened up sharepoint designer, and copied over the register page directives from an existing master page, and somehow, the sharepoint web controls are now recognized again.
share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.