Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

We integrated Sharepoint 2010 with RMS, I don't want the users to be able to "Save As" a document to their local computers. How can I disable "Save As" button on documents?

share|improve this question
add comment

2 Answers 2

Try to grant your site users the "Viewer" permission which will not allow downloading documents from your site. You can apply this permission at the document library level or just for the specified document by stop the inheriting permission button from corresponding permission settings page. here is a detailed explanation: http://office.microsoft.com/en-us/windows-sharepoint-services-help/permission-levels-and-permissions-HA010100149.aspx

The other useful option will be change the default open document behavior from "Client Program" to "Web Browser", you can do this in the Advanced Settings of your document library. reference link: http://technet.microsoft.com/en-us/library/ee837425.aspx

share|improve this answer
add comment

You can leverage Information Rights Management (IRM) to protect your content from floating randomly around outside your SharePoint document libraries.

share|improve this answer
    
Hi, But there's only menu disable printing document, no menu used to disable "save as" button. –  Troy Aug 31 '12 at 11:12
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.