Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

following this processes: http://office.microsoft.com/en-us/sharepoint-server-help/demo-deploy-an-administrator-approved-form-template-HA010205047.aspx

I am trying to upload a form containing some C# code created in infopath 2010 into my sharepoint 2010 site as a site collection admin. In order to do so, I have to submit the form first to be approved and enabled by a site collection administrator. When I upload it in central administration and enable it in the list of infopath form templates, I thought I was supposed to see it on the site form library, but I do not see it there and therefore cannot enable it as a site feature. What step by step processes do I need to take to get this working?

I have tried to enable some features first of all but ran into the problem of not being able to see the site collection features even though I am a site collection admin. (this solution below is not working for me because I still cannot see it, only site features). Has anyone ever encountered this? I have the same problem as Michael in the comments section of the below solution. I am sure I am a site collection admin but I still can't see site collection features in central administration.

http://moustafa-arafa.blogspot.hk/2010/05/cant-see-site-collection-features-in.html

If you are trying to find out "site collection features" link in the site setting page in sharepoint 2010 and you couldn't find out the site administration section at all this is because the logged in user doesn't have a permission as a site collection administrator, open central administration site:

1) Select application management tab. 2) Click on change site collection administrators link under site collection tab. 3) add your self as site collection administrator. 4) refresh the site settings page and you will see all site collection administration section.

Michael said... Hey thanks for the reply, I went back and made sure I was the admin of the site collection before checking site settings. But I don't see a "site collection features" option there either.

May 17, 2010 3:07 PM

Update 1. Trying Gennady's suggested soltuion, but still encountering the same problem:

  1. under Central Administration/Site Actions/Site Settings, I see the following clickable choices:

Clickable Choices

-- I confirm I am both a site collection admin and a member of the farm administrators group.... I can upload the file onto Central Administration but am not able to send it to the Site so far...

share|improve this question
add comment

1 Answer

I have the same problem as Michael in the comments section of the below solution

IMO (because I am on Sharepoint online without access to Central Administration and not 100% sure what are the differences with on-premise Sharepoint Server setup) "Site Collection Features" are under "Site Collection Administration" upon navigating Site Actions > Site Settings

Though, IMO, it is not used for template form administration approval.

In order to do so, I have to submit the form first to be approved and enabled by a site collection administrator

Server farm administrators verify and upload form templates, after which site administrators can activate and manage form templates on the site collections that they own. Check for more details Manage administrator-approved form templates (SharePoint Server 2010)

Update:
Sorry, I cannot help b/c I use Sharepoint Online (Office 365) where there is no Central administration as well as no administration approval (it is done once for all templates and forever, IMO).

Though I just wanted to mention about discrepancy in that online docs tell about farm administrator, the publishing wizard insists on Sharepoint server administrator.

enter image description here

enter image description here

share|improve this answer
    
thanks for the suggestions. Let me update my post with more information related to your answer. –  fa1c0n3r Aug 28 '12 at 3:47
    
Sorry for wasting your time, this is completely different in Sharepoint Online which I use. Can't help. –  Gennady Vanin Novosibirsk Aug 28 '12 at 8:21
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.