Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

i wrote a power shell script to deploy my wsp to to SP 2010 server. It first checks if the solutions is already there and deployed if yes then retracts and redeploy again. It deploys to a specific web application only. The issue is "Retraction" and re -deployment are taking ages to complete. Though from VS2010 there is no issue and it deploys in no time. I am working with a very basic wsp (just one web part only and another feature receiver that does nothing at all). So I am not sure why its taking so much time. Please suggest.

share|improve this question
1  
Can you share the PS script here? –  Nadeem Yousuf Aug 23 '12 at 7:16
2  
what about if you call stsadm -o execadmsvcjobs after requesting the retractation ? –  Steve B Aug 23 '12 at 7:48
    
if farms are not the same, the data amount on one server might cause it to time out on that SharePoint farm and not the other –  Anders Rask Aug 23 '12 at 11:35
    
Steve B has the right solution, I found the exact same issue in my deployment tool. –  Hugh Wood Aug 23 '12 at 12:20

1 Answer 1

up vote 2 down vote accepted

When you deploy/retract your solutions using PowerShell/stsadm it creates a timer job. That timer job operation is invoked by the sptimerv4/owstimer.exe process in the background and starts every 60 seconds. Sometimes there are other timer jobs in the queue which makes it take longer times. If you're only doing it on a single machine (dev box) you can add the -Local parameter to the cmdlet, this invokes the job directly.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.